Polymer 2.x works in the latest two versions of all major browsers: Safari 9+, IE 11+, and the evergreen Chrome, Firefox, and Edge.

The Polymer library is a lightweight sugaring layer on top of the Web Components APIs. Some features used by Polymer are not (yet) supported natively in all browsers. For broad web components support, Polymer uses the polyfills from webcomponents.org. They're lightweight, work well, and provide the feature support Polymer requires.

With the polyfills, Polymer works in these browsers:

ChromeFirefoxIE 11+/
OperaSafari 9+Chrome
(iOS 9+)
Template Native Native Partial Native Native Native Native
HTML Imports Native Polyfill Polyfill Native Polyfill Native Polyfill
Custom Elements Native Polyfill Polyfill Native Partial Native Partial
Shadow DOM Native Polyfill Polyfill Native Partial Native Partial


  • Templates are supported in Edge, but not IE.
  • Safari supports custom elements starting in 10.3.
  • Safari supports shadow DOM starting in 10.2, but as of 10.3 there are still some known issues.
  • Older versions of the Android Browser may run into some issues - please file an issue if you run into a problem on this browser. Chrome for Android is supported.

See the documentation on polyfills for more information.

Polymer 2.x uses EcmaScript 2015 (commonly known as ES6). The following browsers support all of the ES6 features required by Polymer.

  • Chrome or Chromium version 49 or later.
  • Opera 36 or later.
  • Safari or Mobile Safari 10 or later.
  • Edge 15.15063 or later.
  • Firefox 51 or later.

For other browsers, you should compile your application to ES5.

See the documentation on compiling ES6 to ES5 for more information.